Try wiring it to the Arduino headers. Make sure the board is /not/ attached to the basebord when programming.

Can you try writing the programmer to the Arduino headers instead of the ISP connection?



On 2 Oct 2015 01:51, "David Mandala" <> wrote:
On 9/30/15 7:57 AM, Daniel Thompson wrote:
On 30/09/15 13:20, Grant Likely wrote:
8. USBtinyISP cannot program the AVR using the ISP connector. I have
    checked the programmer with another ATMega328P based board and it is
    working OK.

I can confirm this, my USBtinyISP won't work with the Sensors board (and I tried from both Linux PC and Mac) and does work (from both Linux PC and Mac) on other Arduino's.

I get the following from both Linux and Mac:

avrdude: initialization failed, rc=-1
         Double check connections and try again, or use -F to override
         this check.

Error while burning bootloader.

I used short jumpers to connect the USBtinyISP and the 6 pin ISP connector.  As noted below you can't actually plug the USBtinyISP onto the ISP pins it's too tight a fit.  Board powers up as expected but no joy on flashing the bootloader.

Tomorrow I'll clean my desk off, dig through my Arduino stuff and find a real Arduino and rig to flash it from that.


I've not tried the ISP connector. It may be that we screwed it up
somehow. George, have you tried it? This was the very first batch of
boards, so there are things that I know are wrong and will be fixed
before going into production.

avrdude: Using SCK period of 10 usec
avrdude: initialization failed, rc=-1
Double check connections and try again, or use -F to override
this check.

9. (I suspect you have already discovered this but just in case...) the
    P2 (arduino 1x10) and P3 (ISP) are too close together to allow
    a normal IDC connector to be attached to P3. ;-)

For the next run I want to move the ISP connector down to the same
location it is on a real arduino. That will solve the connector
problem and also make it compatible with more shields.

I'm pretty confused at this point, to the point of suspecting multiple
faults. Next steps for me will be with a continuity tester...

Actually, most of this sounds to be symptoms of a missing bootloader.
Since you can't get USBtinyISP to program the board, do you have an
arduino board handy that you can run the ArduinoISP sketch on? I used
the following instructions for flashing the bootloader:

Will do. I haven't got a proper arduino to hand but I can fudge it with
an old breakout board...

Dev mailing list

David Mandala <davidma at linaro dot org> Public Key id: 45B2D952
Murphy TX, 75094 +1.972.891.8436