Hi Michael,

On 21 April 2016 at 21:24, Michael Eager <eager@eagerm.com> wrote:

On 03/30/2016 05:37 PM, Akira Tsukamoto wrote:
Hi Micheal,

On 03/31/2016 09:21 AM, Leo Yan wrote:
On Wed, Mar 30, 2016 at 12:17:30PM -0700, Grant Likely wrote:
On Wednesday, 30 March 2016, Michael Eager <eager@eagerm.com> wrote:

Thanks Grant --

The HiKeyUEFI instructions on how to flash to the eMMc say to attach
a PC to the UART to monitor the debug status.  The board does not have
a header for the UART installed at J16.  I don't know if this means
that the UART is not available or if I can add the header myself.

Am I looking at the correct instructions?   Is the serial port needed
to flash the firmware?

The UART is optional to reflash the board.

More info for this: For Hikey, SoC's bootROM is default to use USB
OTG to burn firmwares; after 60s' timeout it will switch to usb UART
(from J16) to burn images.

Yesterday Akira shared "Reference Platform Build" page for burning
images, it's quite nice and handy:

The "HiKey Early Access Board" do not have bootloader written.

Please follow the instruction in this section.


Hi Akira --

I've been delayed getting back to setting up the HiKey board.

When follow the instructions you mention, I run into a problem.  The
fastboot hangs when downloading the ptable:

$ sudo python hisi-idt.py -d /dev/ttyUSB0 --img1=l-loader.bin
(' Serial: ', '/dev/ttyUSB0')
(' Image1: ', 'l-loader.bin')
(' Image2: ', '')

('Sending', 'l-loader.bin', '...')

$ sudo fastboot flash ptable ptable-linux-4g.img

Before downloading the l-loader.bin file, I verified that /dev/ttyUSB0 exists.
After downloading, this device does not exist.  LED0 on the board it lit.
I waited about 15 seconds and then ran fastboot.  It does not terminate.

Any suggestions?

I would suggest trying with a few different USB cables. I had a similar problem
the other day and it turned out I had two bad USB cables in a row (quite bad
luck I think...I blame the cat), with the third cable everything worked well and

Before issuing the flashing command you can do: -

>sudo fastboot devices

0123456789ABCDEF        fastboot

To see if the HiKey board has been detected as a fastboot device. If it hasn't
unplug / re-plug / try a different cable.

I've also had issues if other devices are plugged into the USB host ports (e.g.
a USB ethernet dongle), so I normally ensure nothing else is plugged into the
board when doing this.