[Dev] angstrom next hikey kernel build failure: DMA-BUF incompatible with non-GPL

Koen Kooi koen.kooi at linaro.org
Wed Apr 15 17:44:16 UTC 2015


On 15 April 2015 at 19:37, Fathi Boudra <fathi.boudra at linaro.org> wrote:
> On 15 April 2015 at 20:29, Trevor Woerner <twoerner at gmail.com> wrote:
>> Hi,
>>
>> I have setup a hikey build using angstrom-next:
>>
>> $ git clone git://github.com/angstrom-distribution/setup-scripts.git
>> $ cd setup-scripts
>> $ git checkout next
>> $ MACHINE=hikey ./oebb.sh config hikey
>> $ source environment-angstrom
>> $ bitbake-layers add-layer <path to angstrom's meta-96boards>
>> $ bitbake console-image
>>
>> While building the kernel (linux-hikey_3.18) my build fails with:
>>
>> /home/trevor/devel/yocto/hikey/board1/angstrom/next/build/tmp-glibc/work-shared/hikey/kernel-source/drivers/gpu/arm/utgard/Kbuild:37:
>> *** DMA-BUF is incompatible with non-GPL license.  Stop.
>> make[5]: *** [drivers/gpu/arm/utgard] Error 2
>> make[4]: *** [drivers/gpu/arm] Error 2
>> make[3]: *** [drivers/gpu] Error 2
>> make[2]: *** [drivers] Error 2
>> make[2]: *** Waiting for unfinished jobs....
>>
>> Any thoughts on why this might be happening?
>
> fixed with https://github.com/96boards/linux/commit/eeb260bd980a0d053b93ba3f41dd16278546133c
>
> latest code builds fine (commit 7835d9a4)

linux-hikey 3.18 was a bit behing in meta-96boards because I use 4.0,
it's been updated in dizzy and master now. Thanks for reporting it!



More information about the Dev mailing list