[Mezzanine] Sensors board Rev B - call for review (v2)

Akira Tsukamoto akira.tsukamoto at linaro.org
Fri Oct 30 12:12:33 UTC 2015


Hi Grant,

I saw the rev B (2) and it already has 2.2Kohm pull-up register on i2c.
Please ignore my previous email.^^

I had other two reports from my friends who tried to use SPI.

(*)Seems to have signal lost or reflection with impedance mismatching
The SPI bus between HiKey and the SPI device through LS connector never
successfully able to talk each other, unless adding 75ohm register
serial to the SDI.
If the value of register is over or under magnitude like 470ohm did not help.
Also tried push-pull/open-drain or adding pull-up register did not help.
So suggested to have space to put Oohm dummy register on the line of SPI and I2C,
and make it able to tweak the value on the boards.

(*)The 5V rail.
The 3.3V rail is clean since it is created by LDO from 5V on the board but
5V rail has only 0.1uF by-pass capacitors on the board.
The 5V rail is from 96boards through LS connector.
The 5V rail is made on both HiKey and DragonBoard by buck switching converter
and has switching noise.
My friend suggested me that pull-up registers connected to 5V will
injects noise to the SPI and I2C.
So suggesting adding two 10uF capacitors on 5V rail.

The board layout looks pretty crowded and
I do not know it has enough space on the board for the above comments.....

Akira


On 10/28/2015 09:30 PM, Akira Tsukamoto wrote:
> Hi Grant,
>
> I read your comments regarding I2C to Uchida-san and the comment on the doc
> https://docs.google.com/document/d/1GNoC-1C1xcejgLLvgm1JbpF7blwJigXq5XIB3FvnuIE/edit#heading=h.t94cutr0c4ae
>
> I looked the datasheet of TXS0104 which is used for level shifting from 1.8V I2C to 5V I2C.
> http://www.ti.com/product/txs0104e
> The block diagram of TXS0104 shows that there are 10Kohm pull-up register inside,
> which is common value for regular pull-up register when converting from
> open drain TTL to data bus on CMOS IC.
> Also, on the datasheet, it says 2Mbps capability for open drain bus,
> so it should not cause any problem.
>
> I remember even I used "10Kohm" pull up register when I was connecting
> 74LS TTL to 74HC series when I did not have 74 HCT series.
>
> So TI's 10Kohm should not be problem according to the specification,
> but when I goodled about I2C transmission problem that data not reaching
> to the end of I2C bus, many people have been tweaking the pull-up register
> to be in between 2Kohm to 5Kohm to improve the compatibility of
> sending data reaching to the end of I2C bus.
> http://www.picfun.com/midi2c02.html
> (sorry it is in Japanese, but only the last sentence is important)
>
> It looks like adding 3.3Kohm next to
> from B1(13) to B4(10) on TXS0104 would make the pull-up value to be 2.48Kohm,
> which might improve the situation.
>
> If you have already done modification for a pre-production run next week,
> please ignore all of this. :)
>
> I also welcome any idea or comments on this.^^
>
> Or having extra space for adding any value on the line of B1 to B4 and
> able trying different value from 2.2Kowm to 4.7Kohm for the person
> who has an oscilloscope before finalizing the value for the real production
> might good. ^^
>
> Akira
>
> On 10/28/2015 03:19 PM, Grant Likely wrote:
>> On Wed, Oct 28, 2015 at 11:56 AM, David Mandala
>> <david.mandala at linaro.org> wrote:
>>> On 10/27/15 9:26 PM, Grant Likely wrote:
>>>>
>>>> On Wed, Oct 28, 2015 at 6:06 AM, David Mandala <david.mandala at linaro.org>
>>>> wrote:
>>>>>
>>>>> On 10/27/15 1:25 PM, Grant Likely wrote:
>>>>>>
>>>>>>
>>>>>> Second posting. I've made some changes to the design. Things to note:
>>>>>> - VIO is selectable between 3.3V and 5V with a slider switch
>>>>>> - A through-hole stackable header is used
>>>>>> - silkscreen is cleaner
>>>>>>
>>>>>> I think that covers all the outstanding comments. Attached are the
>>>>>> schematic, design files, and a rendering.
>>>>>>
>>>>>> Comments welcome. I hope to send this for a pre-production run next
>>>>>> week.
>>>>>>
>>>>>> g.
>>>>>>
>>>>>> Inline image 1
>>>>>
>>>>>
>>>>> Grant,
>>>>>
>>>>> This looks very nice, so +1 from me.
>>>>>
>>>>> Do you have a mechanical layout with measurements for each connector? If
>>>>> so
>>>>> I can get started on the Case additions for this now.
>>>>
>>>>
>>>> Look a the Sensors-layout.pdf file that I sent you. All of the
>>>> information you need should be there.
>>>>
>>>> g.
>>>>
>>> Grant,
>>>
>>> Whoops I missed that.
>>>
>>> That is most of what I need but P2, P3, P4, P5 are missing Y coordinates,
>>> 96B_SPI, P6, SW1 are missing x and y info.
>>
>> Try the attached file.
>>
>>>
>>> I'm guessing that 96B_SPI GPIO2 and I2C0 are 7mm apart from the row above
>>> but it's not called out.  If so that takes care of the y for them, but still
>>
>> Correct
>>
>>> need the X for 96B_SPI it's smaller then the connectors above it.
>>
>> Done
>>
>>>
>>> I am assuming that:
>>> A0,                             D7
>>> A1,                             D6
>>> A2,     A6,     I2C1 top        D5
>>> AT-I2C  GPIO3   I2C1 bottom     D4
>>> respectively share the same Y offsets.
>>
>> Yes
>>
>>> I am also assuming that AT-I2C, GPIO1, I2C0 and D3 y offset is 0 the front
>>> edge of the board.
>>
>> Nominally, yes. No guarantees though.
>>
>> g.
>>


More information about the Mezzanine mailing list